반응형

자바11 사용을 위해 전자정부프레임워크 최신버전인 3.10을 설치하여 환경 구성을 하는데 js파일을 열면 에디터로서의 역할을 하지 못하고 모두 검은색으로 나오는등 오류가 발생했습니다.

 

결론은 전자정부 프레임워크의 뼈대가 되는 이클립스 4.16 버전 오류라고 하는데 마켓에서 추가 설치를 통해 변경할 수 있습니다.

 

아래는 참조글입니다.

www.egovframe.go.kr/home/qainfo/qainfoRead.do?pagerOffset=0&searchKey=&searchValue=&menuNo=69&qaId=QA_00000000000020192

 

묻고 답하기 | 표준프레임워크 포털 eGovFrame

처리중입니다. 잠시만 기다려주십시오.

www.egovframe.go.kr

전자정부프레임워크에 자바스크립트 에디터 효과 적용하기

Help - Install New Software...

Work with :  부분에 http://download.eclipse.org/releases/photon 입력 후 엔터

 

검색 된 내용중 하단에 Web, XML, Java EE 로 시작하는 부분에서 원하는 기능 체크 후 설치

(저는 전체 선택하고 설치했습니다. javascript만 설치하셔도 됩니다.)

 

설치가 완료되면 재부팅을 하고 js파일을 열어봅니다.

다시 열어봐도 동작을 안하는 경우가 있는데, 이런 경우에는 Window - Preferences 이동 후

General - Editors - File Associations 탭으로 이동합니다.

 

JavaScript Editor가 생겼을텐데 클릭 하고 Default로 변경합니다.

 

이후에 js를 열어보고 이때도 적용이 안된다면, js 파일 우클릭 - Open With - JavaScript Editor로 열어주면 이후부터는 자바스크립트 에디터로 동작이 됩니다.

 

분노의 전자정부프레임워크에서 자바스크립트 적용기였습니다...

반응형
  1. ㅇㅇ 2022.05.10 14:17

    포스트 감사합니다.
    이게 이클립스 프로젝트 포럼에서 토론내용을 쭉 읽어보니까 오류가 아니라 의도된 사항이더라고요.
    TypeScript나 Node.js 등 다른 스크립트 언어들을 지원하기 위해 JSDT(자바스크립트 개발도구)에 의존할 수가 없어서 폐기하기로 했다더군요.
    그 대신 추가한게 Wild Web Developer라는 녀석을 추가해서 Generic Text Editor를 통해 타 스크립트 언어도 지원할 수 있게 했다던데
    이 포스트에서 다루는 버전에 설치된 것이 0.10버전이더군요.

    • Favicon of https://myhappyman.tistory.com Park.S.W 2022.05.10 15:00 신고

      안녕하세요!
      앗! 이클립스 포럼까지 확인하시고 답변 달아주시다니 감사합니다~ 재단에서 의도한 사항이라는것도 알게 되었네요😁

  2. 개빡친홍준표 2022.05.27 17:07

    압도적감사